You are here

May a motor carrier that installed and required its drivers to use an AOBRD before December 18, 2017, install and use a new ELD-capable device that runs compliant AOBRD software after that date?

Yes, until December 16, 2019.

Did this answer your question? If not, please email or call 1-800-832-5660 for more information. 

Last Updated : March 9, 2018
Submit Feedback >